The Weirdest Bug – Lenovo Ideapad S205

Today I offered to help a friend with their new Lenovo S205 which they’d bought a year or so previously, but not got around to using. It had come pre-installed with both Ubuntu 12.04 and Ubuntu 12.10 but wasn’t quite behaving properly.

I thought the easiest option would be to start again, with a nice clean install of Ubuntu 12.04.04 LTS. I attached my trusty USB flash drive, and…

….corrupted display, and no boot.

It turns out you can’t press F12 at boot time, and choose to boot from the USB media in the list that appears. No. You have to go into the boot settings proper, and put the USB media at the top of the list. That was Bug number 1.

So, off goes the install of Ubuntu. All looks good, WiFi working, hotkeys etc… time to reboot and…

….nope. PXE boot ROM kicks in instead. Check the boot settings. Yep, hard drive set to boot before other things, but doesn’t.

Back to booting from USB…. Fiddle with grub settings. No go. OK, re-install with manual choice of partitions…. still no go…. fiddle fiddle…. hours pass…

Finally I notice the drive has an MS-DOS type partition table, despite it booting EFI-style to the previous Ubuntu installs, so I decide to delete it and create a GPT one instead. Still nada…. Add an *empty* EFI partition… re-install… nope…. delete all partitions again…re-install… Voila!
(I’ve no idea which step was the magic one either. Bug number 2.)

So, now Ubuntu booted quite happily, but no WiFi. No worries. Attach an Ethernet cable and let it pull down latest drivers…

…but hang on, it has them all.

Poke about in the terminal for a while and realise the wireless is ‘hard’ blocked. But the wireless switch on the side is in the on position. Moving it disables Bluetooth. Moving it back enables Bluetooth. Still no WiFi, but at least the switch works! Everything driver wise seems to check out. The laptop is adamant that WiFi is disabled by hardware switch. Google. More Google.

What? Seriously?

Yup. On the Lenovo S205, WiFi will not function properly unless….

…the hard disk is the first entry in the boot menu!

Bug number 3, and I hit it because of Bug number 1…

Still, all’s well that ends well, but I never want to see another Lenovo S205 again!

Hello Chromebook

I bought my wife an HP Chromebook 11 for her birthday this week. I’ll admit that part of the reason for my choice of gift was my own curiosity. I wanted to see how good a Chromebook was, and whether it would be a better choice to use in schools than the current (expensive) tablet craze that seems to be going on…

First impressions are that the device is the perfect size and weight. The keyboard is great to type on (I’m using it now), with well spaced keys that have a responsive travel and good tactile feedback. Error-free typing without looking is definitely easy on these things, so anyone who needs to write a lot would find an HP Chromebook 11 very nice. The screen is much better than I expected at this price point, with a very bright and crisps display with excellent viewing angles. ChromeOS is easy to use without training, and of course it plays very nicely with the Google Apps stuff. If you’re a heavy user of Google Apps, I’d highly recommend carrying a Chromebook around with you!

The only snag was the inability to print. Sure, you can collect your docs from Google Drive on another machine with a printer, but that’s a bit clunky. Also, given that we have a networked printer at home I wanted to be able to use that. This is another of those Linux-to-the-rescue stories, so with a bit of tinkering all is well. Here’s my solution:

  • Install CUPS onto my HP Proliant Microserver and add our network printer to it
  • Connect CUPS to Google CloudPrint with some python magic from Jason: https://github.com/armooo/cloudprint
  • Set up an application specific-password to use in my Google Account (just in case…)
  • Give cloudprint the account details
  • In my Google account, share the new Google Cloud Print printer with my wife, so she can use it too.

I still need to tweak things so that the cloudprint connector will start automatically, but I very rarely reboot the server, so not sure when I’ll be bothered to get around to that!